Icon--down-black-48x48 IC-logout IC-up IC_check

Ankündigung

Einklappen
Keine Ankündigung bisher.

Wir bauen eine CNC-Portalfräse?

Einklappen
X
Einklappen
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zitat von Florian112 Beitrag anzeigen
    saberlod ich komme absolut nicht weiter. Kam dieser Fehler bei dir auch?
    So oder so ähnlich. Ich kann mich noch erinnern das bei mir auch ständig ein Fehler bzgl. der LPC1768 kam. Es fehlte eine Datei damit er den Code kompelieren konnte. Ich habe damals verschiedene vscodes geladen und irgend einen gefunden bei dem die fehlende Datei dabei war.
    Hast du die Datei PlatformIO.ini auch entsprechend abgeändert, damit er auf die LPC1768 zugreift?

    Kommentar


      Zusätzlich schau mal ob du nach dem kompilieren des Codes in dem Ordner wo du die Original Firmware gespeichert hast überhaupt ein Ordner mit dem Namen .pio exisitiert. Den genau diesen Ordner braucht es und der hatte bei mir anfangs immer gefehlt. Darin befindet sich dann ein Ordner mit dem Namen build und darin der Ordner LPC1768. Darin wiederum ist dann die .bin Datei.
      So nun noch zum StepperDriver es kann nämlich auch sein das noch folgendes nicht enthalten ist: TMCStepper_ID5513 dieser Ordner samt Inhalt müsste sich ebenfalls dort befinden: \.pio\libdeps\LPC1768 ist dies nicht der Fall bricht das ganze mit diesen oder ähnlichen Fehlermeldungen ab.
      Sind diese nicht da, dann schau mal auf GitHub und suche nach TMCStepper_ID5513 und lade es herunter. Dann einfach an der entsprechenden Stelle einfügen. Danach nochmal kompilieren.

      Kommentar


        Ja die PlatformIO.ini habe ich auch geändert. Was meinst du mit verschiedenen vscodes geladen ? Hab da die halbe Nacht dran gesessen und bin fast verzweifelt Die fertige Datei kann man nicht downloaden oder?

        Kommentar


          Hey Florian. Ich habe auch das gleiche Problem. Ich sitze seit Samstag schon vor VSCode. Ich habe verschiedene Variante versucht.Hat leider nicht geklappt.Manche sagt, es liegt an Marlin. Also habe ich einige Vision versucht.Sogar Firmware von" https://www.youtube.com/watch?v=Vljd9lJXu0E&t=460s " habe ich gekauft. Hat auch nicht funktioniert.
          Angehängte Dateien

          Kommentar


            Dann sind wir ja schon zu zweit. Ich habe gefühlt echt alles probiert. Ich weiß nicht mehr weiter. Ein Kumpel von mir der sich echt damit auskennt war auch ratlos

            Kommentar


              Hast du bereits nachgeschaut ob es in deinem Speicherordner die Dateien gibt?

              schickt mir eine PN mit eurer email Adresse dann schicke ich euch meinen Code zu, den könnt ihr dann auf eure Größe der fräse abändern. Voraussetzung ist jedoch, das ihr alle gleichen Komponenten verwendet habt ansonsten tut sich dann wiederum nichts.

              Kommentar


                Klicke auf die Grafik für eine vergrößerte Ansicht

Name: Bildschirmfoto 2020-10-22 um 21.48.33.png
Ansichten: 64
Größe: 327,1 KB
ID: 3883975
                Danke Saberlod. Du bist der Beste. Leider die selbe Ergebnis. Ich glaube es liegt nicht an Code, sondern an das Programm selbst.

                Kommentar


                  Ich habe auch wieder das selbe Problem. Da ich die selben Bauteile wie Saberlod habe musste ich nur die Tischgröße ändern. Aber dann kommt wieder der selbe Fehler.

                  Kommentar


                    Leider habe ich meinen BIGTREETECH SKR V1.3 noch nicht, sonst wäre ich wahrscheinlich bei diesem Problem mit von der Partie. Aber ich verfolge das Alles mit großem Interesse.
                    LG Paul

                    Kommentar


                      Hallo zusammen,

                      deinstalliert mal bitte Visual Studio Code und installiert es neu. Es kann sein, das irgend eine Datei nicht mitinstalliert wurde.

                      Kommentar


                        zusätzlich solltet ihr die letzte stabile Version von Marlin 2.x herunterladen
                        Zu finden hier auf GitHub https://github.com/MarlinFirmware/Marlin 1.1k.

                        Kommentar


                          Zitat von saberlod Beitrag anzeigen
                          zusätzlich solltet ihr die letzte stabile Version von Marlin 2.x herunterladen
                          Zu finden hier auf GitHub https://github.com/MarlinFirmware/Marlin 1.1k.
                          Auf dieser Seite gibt es auch eine bugfix-datei zum Updaten die möglicherweise zur Behebung des Fehlers beitragen könnte. Siehe weiter unten.
                          LG Paul

                          Kommentar


                            Alles probiert. Immernoch das gleiche Problem.

                            Kommentar


                              Es fehlt dir irgend eine Datei, diese solltest du mal über Tante Gockel suchen. Meist gibt es einen treffer bei GitHub - dann installieren. Evtl. hilf auch ein Downgrade.

                              Kommentar


                                Ich habe auf GitHub viele Einträge gefunden welche das gleiche oder so ähnliche Phänomene beschreiben. Es gibt dort immer unterschiedliche Lösungsansätze. Meist liegt es an der verwendeten Version und ein Up bzw. Downgrade führt zum Erfolg. Jedoch muss bei einem Up oder Downgrade auch der verbliebene Rest des alten aus der Speicherort APPDATA entfernt werden und das geht meist nur händisch.

                                Einfach mal die aktuelle Fehlermeldung welche nach dem Build des VScode herauskommt kopieren und über die Tante eingeben - Da gibt es sicherlich unzählige Treffer. Dann alles genau durchlesen und die ein oder andere Methode versuchen. Das muss klappen! Anders habe ich das damals auch nicht gemacht. War auch fast am verzweifeln.

                                Kommentar

                                Lädt...
                                X